跨越 web 自动化版本选择的坑

本贴最后更新于 853 天前,其中的信息可能已经时异事殊

1、IE

使用ie浏览器进行web自动化测试,selenium-java.jar包和ie驱动是同步的(如下图),所以只需要关注ie驱动和ie浏览器版本如何搭配。

如果你使用ie6、ie7请使用 selenium 2.42或者2.40版本,也就是图中的版本。如果你使用的ie8-ie11推荐使用2.50之后的版本。

镜像地址:https://npm.taobao.org/mirrors/selenium/
image.png

2、Chrome

使用chrome浏览器进行web自动化测试,selenium-java.jar是通用的,只需要关注chrome驱动和chrome浏览器版本是否对应即可。在70.0.3538.16之后,chrome驱动和chrome浏览器是一一对应。之前的版本会有一个notes.txt进行描述(如下图)。

镜像地址:https://npm.taobao.org/mirrors/chromedriver/
image.png
image.png

3、Firefox

使用Firefox浏览器进行web自动化测试,相对于ie和chrome更复杂一些。需要selenium-java.jar、firefox驱动、firefox浏览器都匹配。这个匹配关系在github上firefox驱动项目releases中(如下图)。

地址:https://github.com/mozilla/geckodriver/releases
image.png
image.png

1 操作
luojie 在 2020-08-06 17:45:05 更新了该帖
回帖
请输入回帖内容 ...