谁遇到过搭建 nexus3 环境,提示 jdk 版本问题的吗

今天尝试在 CentOS 上搭建 nexus oss 的时候,启动的时候提示 JDK 版本必须为 1.8。百度了一下,VIM nexus ,然后也照着配置了 JDK 安装目录 ,指定为 jdk1.81 的路径,发现还是报一样的错,有知道怎么解决的吗?

报错截图:

image.png

修改的配置如下:

image.png

  • Q&A
    13 引用 • 171 回帖
被采纳的回答
  • happy

    看看把 INSTALL4J_JAVA_HOME 和 JAVA_HOME 的变量注释掉重启试试?

4 回帖
请输入回帖内容 ...
  • happy

    看看把 INSTALL4J_JAVA_HOME 和 JAVA_HOME 的变量注释掉重启试试?

    1 回复
  • xiaobo

    找到原因了 ,配置文件里面写 INSTALL4J_java_HOME 的配置就可以 , 最主要的是 ,必须要用 jdk1.8.0_261 的版本,jdk1.8.0_251 的版本不行

    image.png

    1 回复
  • xiaobo

    找到原因了,JDK 1.8 的版本问题

  • happy

    👍 大佬来篇搭建私服的文章呀