Appium 全新 2.0 版本特性介绍

本贴最后更新于 330 天前,其中的信息可能已经东海扬尘

关于Appium V2

Appium V2 beta版本在2021年发布,从2022年1月1号开始,Appium核心团队不会再维护Appium 1.x版本了,所有近期官方发布的平台驱动(如Android平台的UIAutomator,IOS平台的XCUITest)不再兼容Appium 1.x,需要基于Appium V2版本。让我们一起看看Appium V2相比Appium 1.x发生了哪些变化:

使用前准备工作:

Appium V2版本目前需要基于nodejs环境进行安装,并且对nodejs的版本也有对应的要求:

  • Node.js version in the SemVer range ^14.17.0 || ^16.13.0 || >=18.0.0
  • NPM version >= 8 (NPM is usually bundled with Node.js, but can be upgraded independently)

这里我们选择直接从nodejs的官网https://nodejs.org/en下载最新的版本:

image.png

Step1:安装Appium V2

npm install -g appium@next

目前Appium V2还未最终正式发布,还属于rc(Release Candidate-发布候选版)版本,在安装时必须要使用appium@next参数进行安装。当Appium V2正式发布之后我们可以使用appium参数来安装。

安装完毕之后检测appium版本号:

appium -v

输出结果为:

2.0.0-rc.3

当Appium V2安装好之后,即可通过Appium Extension CLI(Appium扩展命令行)模式来扩展安装各种平台驱动和插件了。

Step2:安装Appium driver

以Android平台为例,安装UIAutomator2驱动:

appium driver install uiautomator2  //Appium扩展命令行模式

安装完毕之后可以查看安装好的驱动:

appium driver list

输出结果为:

image.png

Step3:启动Appium Server

使用appium命令即可启动:

image.png

appium默认会以4723端口启动,并且在启动的时候会在本地加载已安装好的驱动。

Step4:安装Appium客户端库

选择编程语言的对应的Appium客户端库,如Python对应的是Appium-Python-Client,通过pip进行安装;Java对应的是Java-client,通过Maven或者Gradle进行安装。

这里需要注意,如果之前的项目用到了相关的库,需要将其进行升级以适配最新的Appium V2。

Step5:编写测试脚本

这里以python为例:

from appium import webdriver

caps = {
    "platformName": "Android",
    "automationName": "uiautomator2",
    "deviceName": 'emulator-5554',
    "appPackage": "com.lemon.lemonban",
    "appActivity": "com.lemon.lemonban.activity.WelcomeActivity",
    "noReset": True
}
appium_server_url = 'http://127.0.0.1:4723'
driver = webdriver.Remote(appium_server_url, caps)

需要注意的是:Appium Server在1.x版本时期的访问地址是: http://127.0.0.1/wd/hub, 但是在V2版本上不需要后缀/wd/hub了,如果还用之前的地址访问会出现404。

3 操作
shakebabe 在 2023-07-03 14:56:45 更新了该帖
shakebabe 在 2023-07-03 14:45:36 更新了该帖
shakebabe 在 2023-07-03 14:45:02 更新了该帖
回帖
请输入回帖内容 ...